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1 What are LyX, BETEX and TEX?

IyX is a GUI for the IIEX macros which are used to communicate with the TEX type-
setting engine written in Pascal by Donald Knuth (http://www-cs-staff.stanford.
edu/~uno/) following receipt in 1977 of the proofs for the second edition of volume 2 of
The art of computer programming (1981). Whereas the first edition had been set by the
traditional hot type process, the second had been set by phototypesetting and looked
awful.

The TEX engine was essentially complete in 1982 but development continued until 1989.
However, passing parameters to TEX required detailed knowledge of Pascal. So Leslie
Lamport, then an employee of DEC, created a set of macros which allowed a less sophis-
ticated user to use TEX.

With the agreement of his employers, Leslie Lamport placed these macros in the public
domain and they were taken up and developed with such enthusiasm, in particular by the
American Mathematical Society (AMS) to typeset mathematics, that IWTEX forked and,
in the early 1990s, there had to be a major re-write to bring the main forks together. By
that time Leslie Lamport had handed over responsibility for INXTEX to Frank Mittelbach.

Orem Patashnik (1988) had also contributed BibTgX, a bibliographic database system,
which was taken up and developed to provide a wide range of styles of referencing.

IXTEX became very popular among the scientific, engineering and mathematical commu-
nities in the US and continental Europe but is less well known among people from arts
backgrounds and in the UK.
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In 1998 Matthias Ettrich, one of the founders of KDE, created for IWTEX a GUI initially
called Lynx but later abbreviated to LyX as a result of a copyright claim. A few years
ago development appeared to have faltered until decisions were taken to port LyX to
Qt4, thereby making it platform agnostic, and to make it more IATEX user friendly.
Previously the way LyX implemented IXTEX macros had been hidden from the user;
now, where there is a choice of ways to implement things, this is made more explicit and
the help documentation is being updated to clarify why particular choices have been
made and what experienced IXTEX users can do if they want to do things differently.

There is no need to know about IXTEX to produce good quality documents with IyX
and in most cases the first option which Iy X offers will do the job.

2 TEX

TEX! implements best typesetting practice as set out in the The Chicago manual of style
(University of Chicago Press, 1982). This includes hyphenation by the paragraph, not
by the line, so that the amount of white space between words is roughly equal over the
whole paragraph, spacing paragraphs over the page and placing figures and tables as a
traditional typesetter would do.

Traditional typesetters also use more broadly spaced typefaces for books and narrower
ones for newspapers, ligatures (such as fi, fl and fil) and kerning (making certain pairs
of characters, like V followed by e, closer to each other). The last two are implemented
automatically as part of the TEX algorithms.

For the first Knuth developed a set of Postscript Type 1 fonts for the Computer Modern
typefaces, which are the default in Iy’X and ETEX. More recently, the Latin Modern fonts
created by Bogustaw Jackowski and Janusz Nowacki re-implement Computer Modern
using modern computer technology, remedy some of the weaknesses of the way Knuth’s
original fonts were generated and provide glyphs for every known accent used by a
language which uses Roman script.

To achieve high quality output, TEX expects graphics to be in EPS format to match
the vector graphics of the text output. These are always accessed via a link which
must satisfy traditional Unix conventions — so avoid spaces and most non-alphanumeric
characters other than _ and - in folder paths as these will often halt the program without
throwing up a meaningful error message.

But the key difference between using TEX and any other software to create a document
is that the author needs to know nothing of this. The author says what they want by
providing the content and leaves how the document will appear — font sizes and margin
settings, page breaks and table numbers, running headers and where graphics will be on

the page — to KIEX.

'The name TEX is a representation of the Greek letters T, E and X which start the word from which
we get ‘technical;’ so it is pronounced ‘tech’ as in ‘technical’ rather than ‘teks’




3 BTEX

From its beginnings as a markup language for DEC employees, I¥TEX has spawned
a large number of packages, all of which are available from http://www.ctan.org/
and some of which conflict as it is impossible for an single person to be familiar with
every package. So, as with Linux, people have created distributions which provide
the core packages for users. Texlive created by the TEX User Groups and available
from http://www.tug.org/texlive/ is the one most commonly used within the Linux
community. But, if a user needs a more recondite package, it can be downloaded from
http://www.ctan.org/.

Every TEX document belongs to a document class which supports a number of para-
graph styles; from a single book, article, report, and letter class, there are now additional
classes and several variations on most classes to reflect the different approaches taken in
different countries and sometimes by different organisations. So, for example, some pub-
lishers have issued their own variations on the book class and professional organisations,
such as the IEEE, have issued their own variations on the article class. Some conference
organisers will send contributors their own document class to use in preparing papers
for a conference. The AMS made a major contribution early on by developing a number
of document classes for mathematical publishing.

You can add modules to some document classes in order to include, for example, the
Theorem and Corollary styles in your document if you are publishing a mathematical
text and your publisher does not want you to use one of the AMS document classes.
However, some document classes are more flexible than others and, for general use, 1
recommend the KOMA-Script document classes which are a development of the earlier
Script classes intended to extend Leslie Lamport’s original document classes. They also
have the advantage of reasonable documentation.

Whatever the range of paragraph styles available within a document class, two differences
need to be born in mind.

1. Some paragraph styles, such as Part, Chapter and Section have an asterisked
counterpart. Only use these if you do not want them to appear in a contents list
because only styles without an asterisk can appear in a contents list.

2. Paragraph styles may be nestable or not; with nestable styles such as Itemize
(bullets) or Enumerate (numbered) the bullet or numbering style will alter auto-
matically to reflect the nesting level but, if a style is not nestable, nothing you can
do will make it nestable.

Many document classes also permit a small range of alternative styles for headings and
page numbers, from none at all to fairly complicated. As these vary between document
classes, if you do not like a particular range, you can often obtain an alternative range
simply by selecting a different document class. Some styles also vary between one and
two-sided documents; so you need to think about your ultimate mode of delivery: for web
based or electronic delivery the one-sided settings (Document > Settings > Page Layout) are
appropriate but may not be for a printed text.
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Though tables and graphics are normally placed in floats and complicated mathemat-

ical expressions in what is called display format, small tables and graphics and simple

mathematical expressions can be placed in-line. So, for example, you can include a math-
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ematical formula such as 7 =

or a graphic such as (the Notes icon) in-line and TEX will automatically format the
paragraph to accommodate it.

You can also use a borderless table as an alternative to tab stops (which are never used
by typesetters) if you wish to lay something out in columns but without the overhead
of a table layout as I have done on page 23.

Placing tables and graphics in floats has a number of advantages:

e wherever you insert the float in your document, TEX will place it in the most
advantageous position in the final document

e you can give it a label and cross-reference it so that you can refer back to it
from anywhere else in the document without needing to know its full title or page
number

e TEX will number it correctly (and also correctly cross-reference it elsewhere in the
document) however many other floats, chapters or sections you have added since
you first inserted it

o if using the IyyX GUI, you can close the float once you are satisfied with it, so
you don’t waste time redrawing complicated tables or graphics on the screen every
time you scroll through the document.

Traditional, or proportional, typefaces come in two main groups:

e serif (or Roman), which have serifs or additions at the ends of the lines and curves
of each character, originally intended to avoid the type cutting into the paper, and

e sanserif.

Typefaces without serifs were historically used for larger fonts and typesetters normally
use a single Roman typeface in different fonts for a whole document or match a Roman
typeface for the body of the document with a sanserif one for headings. The advent of
typewriters led to the development of a range of fixed space typefaces, of which perhaps
the most well-known are pica, elite and courier.

Instead of requiring users to know which Roman, sanserif and typewriter typefaces will
match each other, Computer Modern and Latin Modern follow a recent trend of providing
matching typefaces in Roman, sanserif and typewriter, the last being used in KTEX
mainly for computer related material like the URLs in this document.

Traditionally, typesetters use only one type of emphasis, normally an italic typeface,
and IATEX is no different. You can change the type of emphasis and use the much wider



range of emphases, bold, underline and so on, that many people are used to but you will
have to do the work yourself. The standard alternate emphasis is SMALL CAPS.

Font size in KTEX is determined by the font used for the body text, or standard para-
graph style. This is usually 10 or 11 pt. All other paragraph style font sizes in a particular
document class are set relative to this font size. Similarly, all margins, top and bottom,
inner and outer, are set relative to the font and font size. The user can override any of
these settings if they wish but they have been chosen to reflect best typesetting practice,
which varies from country to country in some cases because languages with accents may
benefit from slightly taller line heights.

The default character set for INTEX is Latin-1 (or ISO/IEC 8859-1 — which was created
at DEC where Leslie Lamport worked) but I4TEX allows different input and output
encodings which was helpful in the days before Unicode. KIEX3 will have Unicode
support but that is still some way off because of the difficulty of converting so many
packages to support it. In the meantime LyX supports utf-8 as an input encoding
and Scott Pakin maintains a comprehensive list of the symbols available in IXTEX and
the packages needed to support them at http://www.ctan.org/tex-archive/info/
symbols/comprehensive/.

4 LyX

Iy X implements a useful subset of the ITEX macros which includes the most widely
used mathematical functions but takes a defiantly anti-WYSIWYG approach in part
because of the way IXTEX works but also because:

e the author should have no distractions from the task of entering data

e human-readable text can be used to label references, cross-references, comments
and so on in documents rather than having the links hidden under a WYSIWYG
interface

e continuous updating of a WYSIWYG screen is a waste of computing resources.

Most functions are available through key combinations, drop down menus or context-
sensitive icons giving considerable flexibility to users who prefer one or other input
method.

A preview of the document is available in DVI, PostScript or PDF formats though, with
the increasing availability of PDF readers, PDF IATEX is receiving most development.
If this preview is moved to a different desktop, it can be updated without the need to
re-run all the IATEX macros.

The auto-save function in IxX is by far the best I have ever encountered and its emer-
gency save function as it senses a window crashing usually saves every last change that
has been made. Historically, IiyX preferred every file, figure or database relating to a
particular document to be in the same folder. So, as soon as I opened a new file, I would
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Save As to the folder where I intended to store it and its associated files or links to those
files (though recent releases appear less fussy in this respect). Thereafter I normally
only save IyX documents at the end of a session, one less distraction as you get on with
your masterpiece.

Both gnuplot, the charting program, and xfig, the vector graphics program for Unix and
Linux, became natural partners for I¥TEX; both can export graphics in formats which
IXTEX can use. But LyX also takes advantage of the presence of ImageMagick on most
Linux systems to accept most graphics formats and converts them silently to PNG for
display on the input screen and to EPS for passing to TEX; to reduce the number of
such calls, it caches the conversions for future use in your hidden 1yx folder in /home —
which is why it keeps getting bigger and bigger.

4.1 The LyX interface

The default document class when you open a new document in IyX is article but nowa-
days it is worth going immediately to Document> Settings and changing the Document
class to ‘article (KOMA-Script)’ and the Roman, Sanserif and Typewriter Fonts to Latin
Modern. Also, if you are including references, change the Bibliography to Natbib, if you
intend to distribute documents in PDF format, go to PDF properties, tick Use hyperref
support and fill in the details and, if you don’t want the current date to appear in every
document, go to IXTEX Preamble and enter \date{}. You can then save these changes as
your default document class (unless you intend to use a different class more frequently).

Figure 1 shows the new triple pane interface with the start of this document. To the
left of the text area is the outliner and below it is the IATEX source code for the title.
For most work, I close the outliner and source code panes and use a relatively small
window because it causes less eyestrain. But, as input line length is irrelevant to output
line length, you can choose whatever size input screen you are comfortable with and
customise many aspects of the input screen such as icon and text size with Toolsr
Preferences.

Near the top left hand side of the window, the button marked Title indicates that the
cursor was in the paragraph whose style is Title when the screen-shot was taken. Note
by comparing this input with the output that, when the words Iy X, IXTEX or TEX are
output, they each have an idiosyncratic style of typesetting which is applied automati-
cally.

I have used Ctl-Enter (represented by the red arrows in Lyx and \\ in the IATEX source)
to break the title into three lines, the standard way of changing the default layout of long
headings, captions or cell entries. The author and date normally follow the title; putting
in a specific date overrides the default current date if you have not already avoided this
by putting \date{} in the I TEX preamble.

The footnote which follows the date illustrate another standard feature of IyX; floats
and footnotes are placed on the input screen near the text to which they refer. The
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Figure 1: The LyX interface

actual position of the footnote is calculated when the document is processed by TEX. In
fact, the referencing style for the footnote is left until then and whether the footnote is
indicated by an asterisk or by a number follows typesetting rules.

To the right of the Title button is a row of standard icons followed by Emphasis, SMALL
CAPs and an icon to select the last text style you selected with Edit> Text Style; next are
the icons to insert maths, a figure or a table and to toggle the outliner, the maths toolbar
or the table toolbar. The second row begins with icons for the standard paragraph style
and the four list styles followed by the nesting icons and icons for most of the items in
the Insert drop down list. The last two, from the Edit drop down list, allow you to alter
the text style or the paragraph settings. The third row contains the icons for creating
and updating a DVI, PDF or Postscript preview in a viewer.

If you open more than one file at a time, each file is identified by a tab and you can
also split the screen horizontally or vertically, for example, to view different parts of the
same document simultaneously.
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Figure 2: The graphics window

4.2 Graphics, tables, floats and cross-references

You can insert a graphic or a table directly into a document by selecting the icons in the
first row; selecting the graphics icon or Insert> Graphics gives you the graphics window
(Figure 2). Selecting the table icon allows you to select the number of rows and columns
graphically; if you select Insert > Table, you get the standard window asking you to specify
the number of rows and columns.

But in most cases, it is better to place a graphic or a table in a float and the icons for
these are on the second row next to the nesting icons. Each offers you a placeholder
for the caption and you can then choose to place the figure or table above or below the
caption within the float. Once you have inserted the graphic or table into the float, you
will find it is left-justified. If you want it centred or right-justified, make sure the cursor
is to one side of it and select Edit>Paragraph Settings to change it.

In practice, you may want to scale or rotate a graphic; Figure 2 shows the graphics
window with the file selection, scaling and rotation options. The last two do not affect
the input screen, only the output. So, for example, you can rotate a float table in the



output but continue to work on it in normal orientation in the input screen. Scaling
for the output screen has to be done manually; I normally view the initial result in a
viewer, put in a likely figure if it is too big and update the viewer to see if I need to
make a further adjustment. To change the input screen display size select LaTeX and
LyX options.

You can label almost anything in Ix7X by selecting Insert> Label or clicking on the label
icon when the cursor is at the start of a paragraph but it is sensible to restrict yourself
to things like chapters, sections, captions for figures or tables and items in a Descrip-
tion paragraph style. This inserts a link in the file which you can cross-reference from
anywhere else in the file.

Figure 3 shows this process once it was complete. I had entered the words ‘The graphics
window’ in the caption holder within the float and then placed the cursor at the start
of the caption before selecting the label icon. To help you remember each link, IyX
offers you a human-readable description of the link, in this case fig: The-graphics-window,
which helpfully includes a prefix in case, for example, a section and a figure have the
same title. You can edit this or change it later if, for example, you decide to revise the
wording of a section title but note the lack of spaces if you do decide to change it. The
human-readable description is for your benefit; LyX doesn’t use it.

After I had accepted this label, I could select Insert> Cross-Reference or the book icon
and then select this link from the list of existing labels and enter it after ‘Figure’ The
greyed out box tells me that I have inserted a cross-reference to the object labelled
‘fig: The-graphics-window’ here. The default cross-reference is to its number; so, when
IXTEX has worked out what the correct number for this figure is going to be in the final
document, it will insert the correct number in place of the cross-reference. (Note that
LyX is telling me that, so far, it will be Figure 2, not that it will definitely be Figure 2).
But there are other cross-referencing options; for example, you can get it to refer to
something ‘on page n’ as I did on page 4 (and have just done once more). In fact, this
option is even more intelligent; if ‘page n’ happens to be the same, previous or next
page, it says ‘on this/the previous/the following page.

Having closed the label window, which I had re-opened for this screen-shot, I clicked on
the ‘Float: Figure’ box to close the float before continuing working.

Being able to insert tables, figures, references and so on and then to refer to them from
anywhere else in the document without needing to know what number they will have or
where they will be in the final document while being absolutely sure that every number
in the final document will be correct is a huge time-saver for any author or editor.

As graphics are always inserted as a link, it is easy to update a graphic without even
opening LyX. Next time the document is previewed or printed, the new version of the
graphic is used and, as long as you have not changed the dimensions of the graphic, all
will be well. However, tables are another matter.

You can import tables in CSV format with File> Import>Table (CSV) which creates a
new file with the table in it; you can then paste that table into your document, preferably
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Figure 3: Labelling and cross-referencing

within a float. But there is currently no way of linking a IiyX table with an external table;
so, if you change an external table, you have to re-import it into your LyX document.

Filling and adjusting tables within [§X is extremely simple. When you create a table,
its columns are all narrow; as you make your entries, IryX adjusts the column widths
to suit the entries; if the table becomes too wide for the document, you select Edit>
Table Settings from within a column whose width you want to limit and enter a value
in Width, allowing Iy/X to work out the rest; if necessary, you repeat the process with
other columns until the table fits, when you stop — in many cases much quicker than
laboriously altering every column as you often have to do in other programs. There is
no horizontal scroll in IyX; so, for example, if a table which you intend to output as
landscape extends beyond the left or right edge of the window, you simply move the
cursor into the invisible cells and IyX will bring that part of the table into view.

You can select Editr> Table Settings>Longtable to designate a table as a long table and
decide how you want it to break if it extends beyond the end of the page. You don’t
have to worry about where the break will happen every time you revise the document;
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all will be taken care of.

There are both drop-down menus and a context sensitive toolbar to help you adjust
tables; though officially you can only merge cells horizontally, you can simulate a vertical
merge by nesting tables in the table cells that are not to appear merged.

4.3 Paragraph styles

Everything within a document has a paragraph style; though figures, tables and math-
ematical expressions can appear within a paragraph, when they appear outside a para-
graph, including within a float, they are treated as paragraphs and you have to select
Edit> Paragraph Settings in order to Center them.

A small number, for example, standard, quote and verse, only appear in the main text;
others like title, author, dedication and abstract are intended to appear at the start of
the document. The main groups that most users will use are the headings and the lists.
The headings form a hierarchy — Part, Chapter (books and reports only), Section,
Subsection, Subsection, Paragraph and Subparagraph; the last two normally appear
embedded in the following paragraph in the output, though not on the input screen, for
example:

The Paragraph style By default the paragraph styles called Paragraph and Subpara-
graph are not numbered and do not appear in the contents list but you can change these
options in Document > Settings> Numbering; however, their asterisked alternatives have
neither of these options.

If you don’t want numbers for the rest, use the asterisked versions. If you have ap-
pendices, go to the start of the first appendix and select Document>Start Appendix
here; all the subsequent Chapter or Section headings will use alphabetical characters for
‘numbering’ but otherwise the hierarchy will be preserved.

The chapter or section paragraph styles you select will appear under Navigate as will
the captions of any figures or tables or labels you have used allowing you to navigate
easily to any part of the document. If you want to reorder whole chapters or sections or
promote or demote them within the hierarchy select Document> Qutline.

LyX offers four types of list, three of which — Itemize, Enumerate and Description —
are found in IATEX and List or Labelling which is only found in certain KITEX docu-
ment classes but is implemented by LyX through the addition of IATEX macros to those
document classes that do not have it as standard.

I have already used Itemize (bullets) in this document; so Figure 4 illustrates Enumerate
and Description from a glossary of mathematical terms which I compiled during one of
my courses.

11
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Figure 4: Enumerate and Description

With the Description style, the first word of the paragraph appears in bold and the
remainder in normal type; in order to get all the words ‘separation of variables’ and
‘simple harmonic motion’ to appear as part of the expression to be defined, I used Ctl-
space between each word. (I also used Ctl-space after ‘Figure’ to ensure that ‘Figure’
and the number that follow it are on the same line.)

Here the Enumerate (numbered) style is nested in the Description style and a long red
square bracket appears to the left of the paragraphs. With every level of nesting, another

long red square bracket is added so that you do not lose track of nesting levels.

With Itemize and Enumerate the bullet or numbering style changes with each new
nesting level; for example,

1. T can start with a numbered paragraph and add

e a nested bulleted paragraph after which I can add another

2)

nested bulleted paragraph

or even start a nested numbered sequence.

This is a nested standard paragraph to illustrate how you can insert
comments or explanations between elements in a list and still

continue with the numbered sequence.
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Note also how in the output IKTEX lines up the nested standard paragraph
with the numbered paragraph and narrows the space between the lines
to emphasise their connection. All this is done automatically.

2. If I then return to the top level, the space between paragraphs increases and the
numbering carries on; but if I add

e a bulleted (or any other) paragraph at the same nesting level and then try
1. a numbered paragraph at the same nesting level, it restarts the numbering.

Though the nesting icons look like the indenting icons in other software, they do a
significantly different job and the paragraph style interacts with the nesting level to
influence the horizontal and vertical spacing of the text. Nestable paragraph styles
normally only have four nesting levels but they can be combined to create up to six
nesting levels if required.

The List or Labelling style can be used as an alternative to Description but is particularly
useful with timelines such as these extracts from http://www.linux.org/info/linux_
timeline.html:

1992

February What could be described as the first Linux “distribution”, called MCC' In-
terim Linux is released by the University of Manchester, England.

January  alt.os.linux newsgroup created.

Minix creator Andrew Tannenbaum claims “Linux is obsolete” in a posting
to comp.os.minix and starts a public discussion on the merits of Linux in
which Linus Torvalds participates.

1991
December Robert Blum posts the first Linux FAQ

September Version 0.01 of Torvald’s project is made available via ftp.funet.fi. Ari
Lemmke, the systems administrator, gives the directory the name Linuz.

August Linus Torvalds announces that he’s working on an operating system similar
to Minix.

Note how the nested standard paragraph used for the entry starting ‘Minix’ lines up
with the Labelling paragraph style being used.

To change the paragraph style of a single paragraph, select the desired paragraph style
when the cursor is somewhere in the paragraph. Otherwise, use highlighting across all
the desired paragraphs. When pasting a passage containing multiple paragraph styles,
the first paragraph style will take the paragraph style of the insertion point; so you may
wish to change the paragraph style of the insertion point to that of the first paragraph
style in the passage before pasting.
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4.4 Getting the right —, ‘ and space

Typesetters, and therefore TEX, distinguish between what most people think of as a
dash or hyphen; so one of the few quirks of the LiyX interface that a new user needs to
know is the difference between a hyphen, an en dash, an em dash and a minus sign. The
first three are made with one, two or three ‘-’ characters and the fourth by using math
mode.

Name | Output | Made with | Used for
hyphen - -’ Word and line breaks
en dash - - From A-Z; pages 3—-15
em dash — -’ Dash — there it goes again!
minus sign — Ctl-m =7 | 22 — y? = 22

Because TEX was originally developed for 7-bit ASCII systems, it uses the backquote
() for the opening quotation mark and the apostrophe (’) for the closing quotation
mark. Iy X will generally respect quotation marks in utf-8 but, if you import text from
word-processors that use different encodings, you may have to replace them to get the
correct character to appear.

Less obviously, KTEX distinguishes between a full stop after an abbreviation and a full
stop at the end of a sentence and puts more space at the end of a sentence. However,
this algorithm is not perfect as XTEX may think a full stop after a lower case character
is at the end of a sentence and one after an upper case character is after an abbreviation.
So ‘It is I. No it is he’ and ‘Prof. Jones’ may be wrongly typeset. To adjust this insert an
end of sentence full stop (Ctl-full stop or Insert>Special character> End of sentence) after
‘I” and an inter-word space after ‘Prof’ (Ctl-Alt-space or Insert> Formatting> Inter-word
space). This produces ‘It is I. No it is he’ and ‘Prof. Jones! In my experience, this is
less frequently a problem than not using the correct dash.

4.5 The Preamble and TgX code

Because it will probably always be impossible for a GUI to support every IXTEX package
and because LyX is still a work in progress, it has always had the facility to insert TEX
or IATEX code into a document. To insert code that needs to go in the ¥TEX preamble,
that is, before the start of the document, select Document > Settings > IATEX Preamble and
add the relevant code.

To insert code within a document use Ctl-1 , select Insert>TeX Code or click on the TEX
icon. Until IxX 1.6.0 this was the only way of inserting many non-Western European
characters but that can now be done with Insert>Special character>Symbolsi> Category
and selecting from the relevant subset of characters. If you select Display all, it will
display all the characters in the Unicode sequence available for use — inevitably, many
characters are not available!
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Now the major omission in IyX is full support for the book document classes. Typeset-
ters distinguish the front matter of a book from the main matter and, for example, use
Roman numerals for the page numbers in the front matter. To enable this the KTEX
macros \frontmatter and \mainmatter need to be inserted at the start of the book
before the title and before the start of chapter 1 respectively. You also need to use
the Chapter paragraph style for the Foreword, Preface, Acknowledgements etc. in the
front matter even though these are not numbered in a book. They will then be printed
correctly in the contents list but LyX does not yet take account of this and numbers
them as chapters, throwing all the other chapter numbers out. The way round this while
you are working on a book is to insert them as Chapter® paragraph styles until you are
ready to send the document to someone else.

It is advisable not to enter KIEX code for anything which LyX supports as you may
duplicate code or use a macro which conflicts with the way IyX implements KTEX
macros.

4.6 Tables of contents, lists and an index

A book normally has a table of contents and may have lists of tables or figures, a
bibliography and an index — and you may wish to include one or more of these in an
article or a report. All these and more are available under Insert > List/ TOC. The lists will
draw on the headings and captions you have inserted in the document and are updated
instantly if you add, or change the name of, a chapter, section, table or figure — another
huge time saver compared with most other programs.

A bibliography may be added by using the Bibliography paragraph style but most users
will benefit from using BibTEX (Section 6). Creating an index relies on selecting Insert >
Lists/TOCpIndex List in an empty standard paragraph where you want the index to
appear in the document and then selecting Insert > Index Entry or clicking on the tabbed
folder icon when the cursor is at the end of each word or phrase you want to be in the
index. Here the content of the index label is important. IyX offers you the preceding
word as the index entry and you can change that to the preceding phrase or a different
phrase.

For example, in a book I edited I wanted ‘drug users’ to appear in the index; so, each
time I indexed a passage in which drug use was mentioned, I inserted the index label
‘drug users’ even through the words in the text might be ‘drug abuse’ or ‘drug user.’ If
the index label is different, A TEX gives each a different entry in the index. If they are
the same, all the page references are collected under the one index entry. Of course, the
index is only any use if you are going to use LyX or INTEX to produce the final document
as it refers back to the pages in the Iy X or KTEX document. But because it is actually
done at the time of previewing or printing, even if you change the page size or margins
at the last minute, you can be sure that every page reference is still correct in the index.

If you want to know more about good quality indexing or indeed anything about book
publishing, it is worth getting hold of Butcher’s copy-editing (Butcher et al., 2006), the
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UK equivalent of the Chicago manual. It is also possible to use IXTEX macros to compile
more complex indices if you need them.

5 The maths editor

Ly X supported many of the INTEX maths macros from the outset but the maths editor has
changed more than most other parts of the interface as successive developers have tried to
wrestle with the huge number of mathematical symbols needed — most alphabets don’t
have more than 40 characters and so editing text is relatively simple by comparison.

There are really three levels at which you can use the LyX maths editor with any
document class — with a small number of keyboard combinations, with the basic maths
toolbar and with the advanced maths toolbar. You can also insert XTEX maths macros
into a document and you can use an AMS document class.

5.1 Very basic maths

You can enter mathematics in-line with Ctl-m or in display mode, normally used in a
separate paragraph, with Ctl-M (Ctl-shift-m). But you can also use math mode to set
out text in certain contexts; for example, you might want to say that:

Speed — DisFance
Time

Here I began with Ctl-M to obtain display mode and then entered Ctl-m (which also
allows you to enter text as text within maths mode) to enter ‘Speed. This text was
nested in math mode; so I had to move the cursor out of the nested text back into math
mode to enter the equals sign and then the fraction (§ in the basic maths toolbar).
The fraction appeared with two empty containers. I put the cursor in each of these
and entered Ctl-m each time in order to add the text above and below the line. I then
moved the cursor out of all the containers and pressed Enter in order to start the next
paragraph. Had I not entered Ctl-m in math mode in order to use text mode nested
within math mode, I would have got Speed because TEX would have assumed I was

entering a mathematical expression.

The point of using math mode in a situation like this is that the result is perfectly
typeset in a way which, if not impossible, is more difficult to achieve in a word-processor.
However, most people will want to use math mode for more formal mathematics.

Apart from Ctr-m or Ctl-M to initiate math mode, it is worth knowing ~ to add su-
perscripts like powers and _ to add subscripts. You can enter things like 22 — y? = 22
without ever using the toolbar. Note that the output has spaces in the expression which
are generated by IATEX; only in a limited number of situations is it necessary to add
extra spaces when entering expressions in math mode.
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Whenever you use these keyboard combinations, you are creating a nested container
in which to place one or more expressions. When a container is empty, it has a blue
border; when you fill it, the border disappears and is often replaced by red markers at
each corner. These markers can be a little indistinct on the screen but they are useful
when, for example, you pllace a container within another container. For example, to
enter an expression like x2, you follow x with a superscript container and then the two
fraction containers. Having added the 1 and 2 to the fraction containers, you move out
of the fraction containers first, then out of the superscript container and finally out of
the math mode container. As you move the cursor, you will normally see it cross the
boundaries of the containers as marked by the red corners.

You can move out of a container by using Esc or the arrow keys or the space bar if you
are at the end of the expression in the container. Using the space bar elsewhere can
produce unexpected results; so I generally avoid this method though IXTEX users who
are used to ending an expression with a space will find it natural.

5.2 The basic toolbar

Whenever you enter math mode, one or both maths toolbars appear; if both appear,
the 7 icon on the right allows you to toggle just the basic toolbar or both of them. The
first three icons toggle in-line and display mode and allow you to enter subscripts and
superscripts; the square root icon has a single container and the root icon has two. Next
comes the simple fraction icon. The following examples from a mathematical textbook
(Courant and Robbins, 1996) illustrate how IATEX can sympathetically typeset deeply
nested expressions using the simple root and fraction functions:

om \/2—\/2+\/2+...+\/§

% can be expressed as:
1429 =14 =1+t =1+t =141 —=14_L =14 L
611 &I 2+ 153 24 o9 M D 2t
153 153 153 2+ L
76 76

> illustrates the difference between in-line and display mode; if I enter » ;" ; in-line, the
sub- and superscripts appear after the > whereas the same expression in display mode

=1

shows the sub- and superscripts in the correct positions (as also happens with the product
[T and co-product []).

The next four icons offer you the three commonest delimiters and access to the full range
of available delimiters including omitting one of a pair (as I did after [[, having used an
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ordinary ‘(’ to open the parenthesis). Though most keyboards offer you ‘(’, ‘[’ and ‘{,’
these are not scaleable; so you can get odd effects if you include them in an expression

such as M. If you use the equivalent math mode delimiters in, for example, two

2 2 2
2p :FQ) and (prjq ) , the delimiters are scaled to match the

slightly different expressions,

expression. This applies when using the next two icons, to insert a matrix [ CCL d ]

c d

o o a b
inside delimiters or to create an array {

The next four icons allow you to add or delete rows or columns to and from matrices
and arrays, in the course of which the delimiters will change size:

o o
~ Qo

Matrices and arrays have the number of containers needed to match the number of rows
and columns you have specified. (I had to put something in the containers in order to
illustrate the matrices and array in the output though the containers were visible on the
input screen).

Note that the delimiters create a container in which to hold an expression, matrix or
array and so are best entered before the expression though in some cases you can also
highlight an expression and then select a pair of delimiters. This also means that, if you
try to delete a delimiter, you will delete its contents; so cut the contents, delete (not
cut) the delimiter and paste the contents in the math mode container to get rid of an
unwanted delimiter.

The last icon toggles between the basic toolbar and both.

5.3 The advanced toolbar

The advanced toolbar offers a wider range of alternatives such as two smaller styles than
in-line mode, for example: #2—y2=22, several different types of fraction, such as km/n, and
access to a wide range of mathematical symbols. Some of these, like the fractions, create
additional containers.

Before and after the icons for the alternative styles and alternative fractions are the
icons for alternative spaces and fonts; though you can leave the spacing and fonts for
most maths up to KTEX, for some expressions some intervention may be required. The
example given in the LyX help is that, when entering integrals, IyX accepts [ A(z)dz,
and inserts the correct space between [ and A. However, there should be a small space
between (z) and dz and the d in dx is an operator which should be set upright. A thin
space is selected via the spaces icon and the d is made upright by highlighting it and
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either using the keyboard shortcut Alt+C R or selecting the fonts icon and Roman. This
gives: [ A(z)dz. You can make vectors upright bold, as in v, by highlighting them
and using Alt+C R and Alt4+C B or selecting the fonts icon and Roman and then Bold.
(You don’t have to repeat this every time you want to enter a vector — you can copy
and paste it once you have made the changes; for a different vector, just change the
character).

Changing fonts in math mode is different from changing them in text mode. In text
mode, the changed font adds an attribute to the text which the user can turn off at any
point; in math mode it creates a container. In both math mode and text mode, you can
carry on adding characters in the same font if you want but in math mode, when you
have finished, you don’t switch off the attribute, you move the cursor to get out of the
container.

Typesetting certain maths functions requires the alternation between upright and italic
characters and TEX cannot tell whether a sequence of alphabetic characters like tan is
supposed to be t X a X n or ‘tan’ where it means ‘tangent. So in an expression like ‘the
polar form of the complex number z = a+bi = (r,0) = r (cos§ +isinf),” ‘cos’ and ‘sin’
are both inserted from the list of functions that appear when you select CXP and not
typed in as separate letters (in Figure 5 the advanced toolbar is above the basic toolbar
and the function list obscures ?;Ir)l
all the other characters in the expression.

). This ensures that they are typeset upright unlike

Among the functions supported in this way are ‘det’ as in ‘where A = l ¢ 2 ] ,det A =
det (AT) = ad — be, ‘log’ and ‘In’ as in ‘In (sin™ z) = —uln (sinz)” and ‘lim’ as in

N
/ f(z,y) dA = A}im Zf (24,vi) 0A; where §A; — 0 for each ¢ and N — oo
S =1

A in the ‘det’ example illustrates the next icon, for adding decorations to one or more
characters, for example, to indicate vectors. The decoration creates a second container
into which you can place one or more characters or symbols, for example, P—Q}, but in
order to get out of the decoration container, you have to make two cursor movements or
use Esc.

The remaining icons in the advanced toolbar provide access to the wide range of math-
ematical symbols one might need including big operators, such as >, a range of miscel-
laneous operators, such as V and R, the Greek characters, such as A, a multiplicity of
arrows, such as <, smaller operators, such as N, and relationships, such as #. (Though
it is possible to cancel characters in IATEX, this does not always produce a typographi-
cally attractive result. So a number of cancelled characters like # have been created to
produce a more pleasing result).

Apart from the dots icon, the remaining icons provide, for the most part, alternatives
developed by the AMS for those who prefer these to the standard symbols. If you are
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Figure 5: Advanced maths — AMS styles and toolbars

using a lot of symbols associated with a particular icon, you can add a toolbar for these
symbols with View > Toolbarst> Other toolbars.

5.4 The AMS document classes and more

If you are producing a mathematical document, ensure that the AMS and esint packages
are enabled in Document > Settings > Math options; you can add paragraph style modules
with Document > Settings> Modules to a general document style or use the AMS docu-
ment classes which incorporate paragraph styles such as Theorem, Corollary, Lemma,
Proposition and Conjecture, all of which have numbered and unnumbered (asterisked)
versions. Figure 5 illustrates three of these styles in use (as well as the tabs when
more than one document is loaded). You can also insert numbers after mathematical
expressions in display mode and cross-reference them within the document.

If you intend to use any of the features of the advanced toolbar or the AMS document
classes, it is worth reading the IyX maths help — even seasoned KIEX users will gain
from it.
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6 BibTEX

You can insert references into a LyX or KIEX document by using the Bibliography
paragraph style. That may be enough for you if you only insert a handful of references a
year into relatively short documents. But, if you frequently use references, particularly
within long documents, the benefits of using BibTEX appear to increase exponentially
the more you use it. However, you can only use the Bibliography paragraph style and
BibTEX in the same document with the addition of some IATEX macros; so it is better
to choose one or the other for each document you create.

BibTEX was written by Orem Patashnik (1988) to work directly with TEX and, like pretty
well everything to do with TEX, it has acquired many extensions and even some different
versions to deal with problems not originally envisaged in the 1980s. Development of
BibTEX has all but ceased following the development by Philipp Lehman of biblatex
which is now in beta and is expected to be incorporated in TEX distributions in the
not too distant future. The documentation is available from http://www.ctan.org/
tex-archive/help/Catalogue/entries/biblatex.html.

BibTEX has two main elements: a bibliographic database and a bibliographic style. All
the bibliographic styles will be superseded by biblatex which uses IXTEX macros rather
than communicating directly with TEX; but the bibliographic database will be retained
for biblatex — so it is worth knowing about it.

6.1 The BibTgX database

The structure of a BibTEX database, which is possibly unique in allowing records with
different structures to co-exist within the same table, is

ORECORDTYPE{identifier,fieldnamel=contents,fieldname2=contents, ... }

The first part determines whether the record refers to a book, article, chapter in a book,
thesis, etc. The identifier acts both as the index key for BibTEX and as a human readable
identifier for the user to identify a record in a file; so it needs to be created with care.

There are about twenty potential record types, some of them duplicates, each of which
has a small number of mandatory fields and normally one or more optional fields. You
can also create your own fields if you want to store additional data about a particular
reference.

Alphanumeric fields are enclosed in double inverted commas but square brackets can be
used if it is necessary to use double inverted comments within a field. Numeric fields
like volume number can be changed to alphanumeric fields by enclosing the contents in
double inverted commas if, for example, volume numbers are expressed as Roman and
not Arabic numerals. The best summary of the available record types and fields is in
Tame the BeaST by Nicholas Markey (2005) available from CTAN.
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3 publisher = "Routledge {.&} Kegan Paul",
year = 1981,
address = "London™,
edition = " "
note = " "

ISBN = "@ 7108 @788 4",
}

@ARTICLE{smithmadquakers,

author = "Smith, { Revd} Sydney",
title = "{Mad Quakers}",

year = 1813,

journal = "Edinburgh Review",

volume = 23,

pages = "189--98",
month = " ", D
note = "Review of 5|. Tuke (1813) { {Description of the Retreat, an
institution near York, for insane persons of the Society of Friends:
Containing an account of its origin and progress, the modes of treatment,
and a statement of cases . . .}} York: W Alexander”,

<>

Line: 14,638 Col: 23 INS LINE rse.bib

Figure 6: A BibTEX database

Figure 6 shows an extract from a BibTgX file with syntax highlighting; record type is
blue, the identifier green, the field names brown and the alphanumeric fields red. The
black fields are all numeric though the normal three letter abbreviations of the month
can substitute for a numerical value in the month field.

Many reference styles abbreviate personal names to initials and make titles lower case.
So in the second record, \relax is added to ‘Revd’ to ensure that it is not abbreviated to
‘R’ and both it and ‘Mad Quakers’ are placed in braces to ensure that they are excluded
from normal processing. The note field is not subject to any processing; so I have had
to add the \textit macro to ensure that the title is printed in italics; this is handled
automatically in the book title and journal fields. In the first record I had to precede
‘&’ in ‘Routledge & Kegan Paul’ with \ and enclose them in braces to ensure that it is
not processed as a TEX command (see Section 6.2.3).

6.2 Tips for entering data
6.2.1 Authors and editors

Book references may have an author field, an editor field or both. For an @BOOK record,
use either the author or the editor field (not both); for an @INCOLLECTION record, that
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is, a reference to a chapter in a book, there will be the author(s) of the chapter and the
editor(s) of the book.

You must use ‘and’ between the names of multiple authors/editors in the author and
editor fields, however unnatural this may look, because BibTEX uses ‘and’ as the delim-
iter. Where appropriate, ‘et al! will be used in the citation (Figure 8) and the names
will appear in the reference with commas between all but the last two, as on page 27. If
you want to force ‘et al. in a reference, perhaps because you are citing a research paper
to which lots of researchers have contributed, use ‘and others’ in the BibTEX record.

6.2.2 First von Last

BibTEX expects names to consist of two or three parts; if the author is an organisation,
you need to put the whole name in braces to prevent BibTEX breaking it up. Otherwise,
BibTEX looks for the most sensible way of breaking up a name into first names, a ‘von’
part (for which you may need to use \relax) and a last name. You can help by entering
names as ‘lastname, first names’ but you don’t need to; BibTEX will try to make sense
of whatever is there. If you get unexpected results, Nicholas Markey (2005) gives an
excellent account of the ways to handle different types of name.

6.2.3 Common non-alphabetical characters

Because IXTEX uses certain non-alphabetical characters as part of its syntax, they need
to be distinguished in BibTEX files.

Character expressed in BibTEX Character expressed in BibTEX

# {\#} { (N3

$ {\$} } {\}}

%o {\%} ~ {(\~{3}

B ({33 / {\/7}

& {\&? \ Use mathmode
A\

6.2.4 Accents

Because BibTEX was created long before Unicode became a viable option, it expects
macros for accented characters. The main Western European accents are expressed as
follows:

Character expressed in BibTgX Character expressed in BibTEX

e acute {\’e} o circumflex {\"o}
e grave {\‘e} n tilde {\~n}
¢ cedilla N\c{c}} u umlaut {\"u}

For the rest download Scott Pakin’s list of symbols from CTAN.
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Figure 7: Inserting a BibTEX database

6.2.5 Empty fields

For the most part, an optional empty field will cause no problems. But some biblio-
graphic styles will stop reading a record once they encounter an empty optional field. So
it is generally prudent to delete empty optional fields which come before your last filled
optional field. Note also that, where you have a choice of volume or number, you must
not include both fields even if one of them is empty.

6.3 Adding the BibTEX database file

To add a BibTEX database file to your LyX document, use Insert> Lists/ TOC> BibTEX
Bibliography in an empty standard paragraph where you want the references to appear in
the document. Selecting Add will offer you a number of example files; so select Browse in
the pop-up window and, if your BibTEX file is in the same folder as your LyX document,
it will be there to be selected. Once you have selected it with Open, it will appear in
the Databases window.

Figure 7 shows the interface as it appears? when selecting a database (though, as you can
see from the Databases window, after I had in fact made the selection); the top window

2The dimming of the windows behind the top one in Figure 7 is a ‘feature’ of KDE4
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lists the example databases and the Browse option opens the file selection dialogue that
enables you to select your database; in the second window it is just possible to see on
the left that the chicago style has been selected (though the scroll bar to select it is
hidden); on the right is the Browse option which allows you to use a style of your own.

Ly X supports a range of bibliographic styles directly. If you don’t know which to use and
prefer numerical citations, choose plainnat; if you prefer author-year, choose chicago;
then OK the dialogue. Both need Natbib enabled as described in the next section.

6.4 BibTgX styles

As with most things to do with TEX and IXTEX, BibTEX quickly acquired extensions,
particularly Natbib, created by Patrick Daly (2009), and later Jurabib which allow you to
vary the the citation between, for example, ‘(Daly, 2009),” ‘Daly (2009)’ or just ‘(2009),’
to add comments like ‘for example’ before or page numbers after a citation or, in the
case of Jurabib, to use ‘ibidem.

A number of Natbib styles, like plainnat, duplicate an original bibliographic style in
the references but allow the author to choose between leaving Numerical enabled or
enabling Author-year. Others, like chicago, benefit from Author-year being enabled
via Documents> Settings > Bibliography > Natbib > Author-year so that you can use all the
different citation styles that are associated with author-year referencing. The most recent
summary of Natbib is available from CTAN and there is a catalogue of BibTEX styles
at http://bradlug.co.uk/?page_id=85.

6.5 Inserting citations

Once you have inserted the link to the BibTEX database, you can begin to insert citations.
Figure 8 shows the dialogue you see after selecting Insert> Citation or the icon that looks
like a bunch of papers.

The upper left window lists the identifiers from the BibTEX database (a scroll-bar would
appear if there were more). butchercopyediting is still highlighted because I have just
selected Add and it has appeared in the upper right window. You can create multiple
citations at the same point in a document by selecting and adding further citations to
the upper right window and there are options to move citations up and down in that
window in order to change the order of their citation.

Below these windows, the contents of the highlighted BibTEX record appear as a CSV
record showing ‘and’ being used as a delimiter and the braces I added to force BibTEX
to capitalise the ‘C’ in ‘Cambridge.

This display is helpful if you have two similar identifiers and have forgotten which refer-
ence you want to cite. It also helps if you have entered a foreign character not recognised
by BibTgX, as they often shows up in this window allowing you to alter them before
trying to use the reference and throwing up an error message.
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Available Citations: Selected Citations:
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courantrobbins Delete
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knuthart1

knuthart2fundamental

knuthart2Zseminumerical

markeybeast L
patashnikbibtexing Up
patashnikstyles ~
saundersoverly v Dawn

] >

Butcher, Judith and Drake, Caroline and Leach, Maureen, Butcher's copy-editing: the
{C}ambridge handbook for editors, copy-editors and proofreaders, Cambridge University
Press, 2006

<>

Search Citation

Find: Gal
Search Field: All Fields » Regular Expression
Entry Types:  All Entry Types v Case Sensitive

Search As You Type

Formatting
Citation style: | (Butcher et al., 2006) w
Text before: utcher etal (2006

(Butcher et al., 20

Full autha Butcher et al. 2006
~ Butcher et al., 2006
Butcher et al.
Restare 2006
(20061

Figure 8: Inserting a citation

If you have a very large BibTEX database (700 entries is the maximum recommended
size) or have forgotten the identifier, you may want to use the search facilities to locate
the record.

The lower part of the dialogue contains the Natbib extensions which allow you to specify,
among other things, how the citation will appear in the text. You can see that Natbib
is using ‘et al’ in the citation because there are more than two authors and that I have
chosen the option to have the entire citation in parentheses with a comma before the
year. Below are the Text before and Text after dialogue boxes (the latter hidden) and
two further options for handling references.

If you have not enabled Natbib or Jurabib in Documentsi>Settings> Bibliography, the
lower part of this dialogue will be inaccessible — a useful reminder if you have rushed
to insert the link to the database but forgotten to enable one of them.

26



6.6 Sectioned and multiple bibliographies

Though LyX does not support sectioned or multiple bibliographies as standard, it does
support the bibtopic package; so it is possible, by adding some IATEX macros, to add
these as explained in Help > Additional Featurest Supplemental Tools.

6.7 The power of BibTEX

You really begin to appreciate the power of BibTEX when you are dealing with multiple
complex references; apart from the fact that, once you have the correct reference in your
database, you know that it will be correct in every document you produce, where you
cite multiple references by the same author in one year, Natbib will add the ‘a’, ‘b’, ‘¢’
to the year in the citation and the references and ensure that they are always correctly
cited in your document. It even knows that you use ‘2006a,b’ in an author-year citation
when you cite two references from the same author in the same year at the same place.

If your publisher wants a different style, there are only a few extreme changes of style,
like plain to chicago, where you need to do anything more than opening the dialogue in
Figure 7 and changing the style. BibTEX will handle everything else. biblatex promises
even more power and flexibility while using the same database structure.

And finally ...

Apart from the screen-shots and the bibliography which were created separately, every-
thing in this document was produced using different releases of Ly X 1.6 and so it gives
you some idea of how far IyX has come in the last decade. But I have only been able to
scratch the surface of the range of options that the current release (LyX 1.6.4) offers from
versioning to detailed manipulation of the typesetting. There is a wealth of material in
the help documentation which I have never experimented with because, so far, I haven’t
needed to. Maybe you will.
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